Jump to content
  • Sign in to follow this  

    Assignment Record


    Harry Berkley

    Summary: Recently whenever I attempt to make an Assignment Record, it returns a stack trace and error EX0

    Steps to Reproduce: Attempt to make an assignment record either via the assignment record section or by the soldier section

    Expected Results: Assignment record creation and no stack trace

    Actual Results:

    OutOfRangeException:  (0)
    #0 /home/djqlybfm/public_html/forums/applications/perscom/modules/admin/records/assignment.php(155): IPS\Patterns\_ActiveRecord::load(NULL)
    #1 [internal function]: IPS\perscom\modules\admin\records\_assignment->IPS\perscom\modules\admin\records\{closure}(1, Array)
    #2 /home/djqlybfm/public_html/forums/system/Helpers/Table/Db.php(418): call_user_func(Object(Closure), 1, Array)
    #3 /home/djqlybfm/public_html/forums/system/Helpers/Table/Table.php(485): IPS\Helpers\Table\_Db->getRows(Array)
    #4 /home/djqlybfm/public_html/forums/applications/perscom/modules/admin/records/assignment.php(217): IPS\Helpers\Table\_Table->__toString()
    #5 /home/djqlybfm/public_html/forums/applications/perscom/modules/admin/records/assignment.php(44): IPS\perscom\modules\admin\records\_assignment->_setupTable()
    #6 /home/djqlybfm/public_html/forums/system/Dispatcher/Controller.php(96): IPS\perscom\modules\admin\records\_assignment->manage()
    #7 /home/djqlybfm/public_html/forums/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
    #8 /home/djqlybfm/public_html/forums/applications/perscom/sources/Node/Controller.php(29): IPS\Node\_Controller->execute()
    #9 /home/djqlybfm/public_html/forums/applications/perscom/modules/admin/records/assignment.php(33): IPS\perscom\Node\_Controller->execute()
    #10 /home/djqlybfm/public_html/forums/system/Dispatcher/Dispatcher.php(146): IPS\perscom\modules\admin\records\_assignment->execute()
    #11 /home/djqlybfm/public_html/forums/admin/index.php(14): IPS\_Dispatcher->run()
    #12 {main}

    Version/Build: Latest/1.1.4

    Configuration: Not sure what you mean by this

    Sign in to follow this  


    User Feedback

    Recommended Comments

    After looking through the forums and reading some of the code in PERSCOM, I might have found the problem. Will report back.

    Share this comment


    Link to comment
    Share on other sites

    Awesome, glad you were able to get it fixed! By the stacktrace, it appears it is trying to load a non-existent status for the soldier you are transferring. Was this the problem?

    Share this comment


    Link to comment
    Share on other sites

Report A Bug

631676319_LogoHorizontalWhite@4x.png.bd4

 

EMAIL | [email protected]

LOCATION | Bend, Oregon

CONTACT US | Click Here

Latest Posts

Bug Reporting System

×