Jump to content
Daedious

Configuration Error EX1048 on Assignment Submission

Recommended Posts

Customer

Hello,

Tried to create an assignment record and received this error: EX1048 Something went wrong. Please try again.

INSERT INTO `perscom_assignment_records` ( `assignment_records_document`, `assignment_records_notification`, `assignment_records_soldier`, `assignment_records_date`, `assignment_records_from`, `assignment_records_to`, `assignment_records_position`, `assignment_records_status`, `assignment_records_supervisor` ) VALUES ( 0, true, 1, 1549665600, 1, 1, 3, 1, NULL )
IPS\Db\Exception: Column 'assignment_records_supervisor' cannot be null (1048)
#0 /home/inspireworks/webapps/4k/forums/system/Db/Db.php(807): IPS\_Db->preparedQuery('/*IPS\\Patterns\\...', Array)
#1 /home/inspireworks/webapps/4k/forums/system/Patterns/ActiveRecord.php(459): IPS\_Db->insert('perscom_assignm...', Array)
#2 [internal function]: IPS\Patterns\_ActiveRecord->save()
#3 /home/inspireworks/webapps/4k/forums/init.php(460) : eval()'d code(120): call_user_func_array('parent::save', Array)
#4 /home/inspireworks/webapps/4k/forums/system/Node/Model.php(2219): IPS\Patterns\rules_hook_ipsPatternsActiveRecord->save()
#5 /home/inspireworks/webapps/4k/forums/applications/perscom/sources/Records/AssignmentRecord.php(0): IPS\Node\_Model->save()
#6 /home/inspireworks/webapps/4k/forums/system/Node/Model.php(3002): IPS\perscom\Records\_AssignmentRecord->save()
#7 [internal function]: IPS\Node\_Model->saveForm(Array)
#8 /home/inspireworks/webapps/4k/forums/init.php(460) : eval()'d code(83): call_user_func_array('parent::saveFor...', Array)
#9 /home/inspireworks/webapps/4k/forums/system/Node/Controller.php(413): IPS\Node\rules_hook_ipsNodeModel->saveForm(Array)
#10 /home/inspireworks/webapps/4k/forums/applications/perscom/modules/admin/records/assignment.php(0): IPS\Node\_Controller->form()
#11 /home/inspireworks/webapps/4k/forums/system/Dispatcher/Controller.php(85): IPS\perscom\modules\admin\records\_assignment->form()
#12 /home/inspireworks/webapps/4k/forums/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#13 /home/inspireworks/webapps/4k/forums/applications/perscom/sources/Node/Controller.php(0): IPS\Node\_Controller->execute()
#14 /home/inspireworks/webapps/4k/forums/applications/perscom/modules/admin/records/assignment.php(0): IPS\perscom\Node\_Controller->execute()
#15 /home/inspireworks/webapps/4k/forums/system/Dispatcher/Dispatcher.php(146): IPS\perscom\modules\admin\records\_assignment->execute()
#16 /home/inspireworks/webapps/4k/forums/admin/index.php(14): IPS\_Dispatcher->run()
#17 {main}

 

Share this post


Link to post
Share on other sites
Staff

@Daedious we've found the bug. It occurs when filing an assignment record of a soldier who has no supervisor set, and the checkbox for " " is checked. The only way to bypass this bug at this point is to set a supervisor for the soldier you are assigning. We will fix this bug immediately!

Share this post


Link to post
Share on other sites
Customer

Well that makes obvious sense now. I was seeing supervisor as permission not as another table lol

Share this post


Link to post
Share on other sites

Report A Bug
×
×
  • Create New...